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1. Benchmark Problem 1 

 

Figure 1.1 shows the screen that appears when you start THMC. The first screen is composed 

of of 6 menus (Project, View, Tools, Settings, Language, and Help) located at the top of the 

window, and 4 GUIs (Site Hydrogeology Information GUI  , Geometry Mesh GUI  , 

Model Parameter Input & Simulation GUI , and Visualization GUI ) positioned on the 

upper left side of the window. The Site Hydrogeology Information GUI is a GUI that generates 

meshes using shape files produced from GIS and borehole data. The Geometry Mesh GUI 

allows for the manual configuration of the mesh and designates nodes, elements, and element 

sides for initial and boundary conditions. The Model Parameter Input & Simulation GUI is for 

entering material properties, initial values, boundary values, time step sizes, and information 

necessary for numerical simulations, and it also conducts the numerical simulation. Lastly, the 

Visualization GUI outputs the numerical simulation results in the form of graphs or contours 

or in the form of an ascii file. To get detailed input information about the Benchmark problems, 

one can select ‘Project’ →‘Benchmark’ as shown in Figure 1.2. 

 

 

Figure 1.1. The THMC start screen. 
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Figure 1.2. Project menu. 

 

To start a new project, select ‘Project’ → ‘New’. Then, enter the project name. For Benchmark 

problem 1, since it is a 2D numerical simulation, select ‘THMC2D’ in Model as shown in 

Figure 1.3. Then, click 'Confirm'. 

 

 

Figure 1.3. Create New Project. 

 

Next, if you click on the Geometry Mesh GUI  positioned on the upper left side of the 

window, the screen appears as shown in Figure 1.4. The Geometry Mesh GUI includes 6 menus 

(File, Geo Setting, Consist, 3D Setting, Tools, and Canvas Setting). 
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Figure 1.4. Geometry Mesh GUI. 

 

1.1 Geometry Mesh GUI 

 

The Geometry Mesh GUI consists of one panel on the left (Figure 1.5), a large window in the 

center (Figure 1.6), and three smaller windows on the right. As seen in Figures 1.5 and 1.6, the 

Panel on the left side and the Window in the center include many tools. The Window in the 

center has 12 tools on the left side (Add Selection , Minus Selection , Toggle Selection 

, Selection Geometry Nodes, Add new Node with Right Click in ‘Edit Mode’ , Select 

Geometry Lines  , Select Nodes  , Select Edges  , Select Surfaces  , Select 

Volumes , Delete all Selected , Square , Regular Polygon ), and 15 tools on 

the top (Reset unselected species/reaction to selected  , Save Solution  , 

Solid/Wireframe , YZ Plane, Set view direction to +X , YZ Plane, Set view 

direction to -X , XZ Plane, Set view direction to +Y , XZ Plane, Set view direction to -

Y , XY Plane, Set view direction to +Z , XY Plane, Set view direction to -Z , Rotate 
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90º clockwise , Rotate 90º counter clockwise , ObjectMode/EditMode , 

Mesh Generator , Labeling Vertex , and Labeling Cell ). 

 

 

Figure 1.5. Panel on the left side in the Geometry Mesh GUI. 

 

Figure 1.6. Large window in the center in the Geometry Mesh GUI. 
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1. To start a new solution, select ‘File’ → ‘New or Open Solution’ as shown in Figure 1.7. 

 

Figure 1.7. File menu. 

2. In the ‘New or Open Solution’ window, enter the solution name and click 'Create New' as 

shown in Figure 1.8. 

 

 

Figure 1.8. New or Open Solution. 
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3. To set the interest area, click on the ‘Square’ tool  located on the left side of the window. 

A panel will then appear as shown in Figure 1.9. After entering W=50 and H=200, click on the 

'Preview' button followed by the 'Create' button. When you click the 'Create' button, an area of 

interest measuring 50 cm by 200 cm appears on the window as shown in Figure 1.10. 

 

Figure 1.9. Square tool for setting the area of interest. 

 

Figure 1.10. The area of interest. 



9 

 

4. Click on the 'Mesh Generator' tool  located at the top of the window. In Benchmark 

problem 1, the area of interest is composed of rectangular elements. Therefore, in the Mesh 

Generator window, click on 'Quadrilateral' . 

 

 

5. After clicking on ‘GEO (d1, n4)’ in the Panel located on the left and then selecting ‘domain 

1’, you can see that 4 Edges and 4 BGs have been created, as shown in Figure 1.14. 

6. In Benchmark problem 1, since the area of interest is divided into 41 nodes in the z-direction, 

right-click on BG1 and input the 'Set Nodes Count' to 41. Then, click again ‘Set Nodes Count’ 

button as shown in Figure 1.15. 

7. In Benchmark problem 1, since the x-direction consists of 2 nodes, right-click on BG2 and 

set the 'Nodes Counts' to 2 as shown in Figure 1.16.  
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Figure 1.14. Domain 1 composed of 4 Edges and 4 BGs. 

 

 

(a) 
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(b) 

Figure 1.15. Divide BG1 into 41 nodes. 

 

 

Figure 1.16. Divide BG2 into 2 nodes. 

 

8. Click on the 'Mesh Generator' tool  located at the top of the window, and in the Mesh 

Generator window, click on 'Quadrilateral' . 

9. The result of dividing the area of interest into 41 nodes in the z-direction is illustrated in 

Figure 1.17. 
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Figure 1.17. Divide the area of interest into 41 nodes in the z-direction. 

 

10. If the mesh has been created as shown in Figure 1.17, one would want to set initial and 

boundary conditions for the area of interest. In Benchmark problem 1 for the initial condition, 

since different values were input for the top, bottom, and the rest of the area of interest, we will 

specify initial conditions for each of these three parts separately. First, with 'Add Selection' 

 selected on the left side of the window, choose 'Select Nodes' . 

11. To select the nodes located at the top of the area of interest, drag to select the two top nodes. 

The window screen appears as shown in Figure 1.18. 
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Figure 1.18. The window screen after the two top nodes have been selected. 

 

12. In the panel, select 'CreateGroup'  as shown in Figure 1.19. 

 

Figure 1.19. Panel view. 
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13. Then, as seen in Figure 1.20, 'Create Group' window appears. 

 

Figure 1.20. Create Group Window. 

14. In Figure 1.20, click on the list box next to ‘2. Simulation Category:’ and select 

'Hydrological'. Then, click on the list box next to '3. Condition Name:' and choose 'Initial'. Then, 

click on ‘Assign to Group Name’.  

15. In Figure 1.20, if you enter 'top' into the text box under ‘III. *Group Name and Number’, 

the result appears as shown in Figure 1.21. 

16. Then, click on ‘Apply and Close’. 

17. Then, as seen in Figure 1.22, you can observe that 'Hydrological_Initial_top' has been added 

under the 'Conditions' subcategory. 
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Figure 1.21. Create Group Window. 

 

Figure 1.22. Panel view. 
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18. To set the initial conditions for the nodes located at the bottom, repeat steps 10 through 16. 

However, in step 11, select the two nodes at the bottom, and in step 15, enter 'bottom' in the 

text box under 'III. *Group Name and Number'.  

 

19. In the final step of setting the initial conditions, follow the same steps 10 through 16 for the 

nodes excluding the top and bottom. During step 11, select all nodes except those at the top 

and bottom, and in step 15, enter 'rest' into the text box under 'III. *Group Name and Number'. 
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20. Then, we will explain how to set the boundary conditions. In Benchmark problem 1, we set 

a variable boundary condition for the top and a Dirichlet boundary condition for the bottom. 

First, to set a variable boundary condition for the top, with 'Add Selection'  selected on 

the left side of the window and ‘Labeling Vertex’  selected on the upper side of the window, 

choose 'Select Edges' . 

21. To select the element side located at the top of the area of interest, drag to select the top 

element. The window screen appears as shown in Figure 1.23. 

 

Figure 1.23. Window screen. 

22. To verify the selected boundary element sides, click the tool  located at the bottom of 

the panel as shown in Figure 1.24. 

23. In the table located at the bottom of the panel view in Figure 1.24, one can observe that the 

boundary sides (81, 82), (82, 41), and (41, 40) are selected. As indicated in Figure 1.23, the 

boundary side corresponding to the top boundary side is (82, 41). Therefore, boundary sides 

(81, 82) and (41, 40) should be removed. 

24. As seen in Figure 1.25, select the boundary sides (81, 82) and (41, 40), right-click, and 

choose 'Remove Selected Mesh Objects'. Then, in the appearing 'Warning' window, click 'OK'. 
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Figure 1.24. Panel view. Figure 1.25. Panel view. 

 

26. As a result, you can see that the top boundary side is selected, as shown in Figure 1.26. 

27. Select 'CreateGroup' tool  located below the Panel, as shown in Figure 1.27. 

28. As seen in Figure 1.28, ‘I. *Shape Type’ has ‘Line’ selected. For ‘2. Simulation Category:’, 

choose ‘Hydrological’. Then, for ‘3. Condition Name:’, select ‘Variable’. Click on ‘Assign to 

Group Name’, and type ‘top’ under ‘III. *Group Name and Number’. Finally, click on ‘Apply 

and Close’. Thus, the variable boundary condition setting for the top boundary side is 

completed. 

29. The process of setting the Dirichlet boundary condition is very similar to the process of 

setting the initial condition in step 18. The only difference is that in step 14, you should select 

'Dirichlet' for '3. Condition Name:' as shown in Figure 1.29. 
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Figure 1.26. Window screen for setting variable boundary condition. 

 

Figure 1.27. Panel view. 
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Figure 1.28. Create Group window for setting variable boundary condition. 

 

Figure 1.29. Create Group window for setting Dirichlet boundary condition. 
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Through steps 1 to 30, we have completed the mesh generation for Benchmark problem 1 and 

finalized the settings for nodes and element sides for the initial and boundary conditions in the 

Geometry Mesh GUI. As shown in Figure 1.30, after setting the initial and boundary conditions 

for Benchmark problem 1, the subcategories are created under the 'Condition' category. You 

can click on each subcategory to verify if the selection has been made correctly. Lastly, to save 

the mesh information, initial and boundary conditions set from step 3 to 29, click the Save 

Solution  located on the upper part of the program. Then, in the ‘Save Geometry’ pop-up 

window, click ‘OK’. 

 

Figure 1.30. After setting the initial and boundary conditions, the subcategories created under 

the 'Condition' category. 

 

Now, we'll navigate to the 'Model Parameter Input & Simulation GUI'  located on the 

upper left side of the program. Here, we will set the time intervals for the numerical simulation, 

configure the material values, and establish the initial and boundary conditions, and then run 

the numerical simulation. 
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1.2 Model Parameter Input & Simulation GUI 

 

The 'Model Parameter Input & Simulation GUI' consists of four tools: 'Import Mesh and 

Boundary Data'  , 'Start Model Simulation'  , 'Stop Model Simulation'  , and 

'Restart' ; as well as four tabs: 'Parameter Wizard', 'Simulation', 'Global', and 'Hydro' as 

shown in Figure 1.31. 

 

Figure 1.31. Model Parameter Input & Simulation GUI'. 

1. To import the mesh information and the initial and boundary condition settings entered in 

the 'Geometry Mesh GUI', click on the 'Import Mesh and Boundary Data' tool . 

2. Then, the 'Mesh Import' window pops up as shown in Figure 1.32. Choose ‘cm’ in unit and 

click on ‘Import’. 

3. To proceed with the numerical simulation, select the 'Advanced' option in ‘View’ menu as 

shown in Figure 1.33. 

4. In Figure 1.34, enter the 'Project Description' and 'Unit' in the 'Parameter Wizard' tab. For 

Benchmark problem 1, the units of cm, g, and day are used, so select the corresponding units. 

Then, in the Module, select 'Fluid Flow' and choose the 'Transient' fluid flow option. 
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Figure 1.32. Mesh Import window. 

 

Figure 1.33. Check ‘Advanced’ option. 

 

Figure 1.34. Parameter Wizard tab. 
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5. In Benchmark problem 1, the initial time step size is set at 0.05 days. Each subsequent time 

step is increased by a factor of 1.2 until it reaches a maximum size of 1.0 day. However, because 

there is a sudden shift in the flux value from 5 cm/day (infiltration) to -5 cm/day (evaporation) 

imposed on the top surface at t = 10 days, the time step size is reset to 0.05 days at that point. 

From there, it will increase again for each subsequent time step using the same 1.2 multiplier. 

The maximum time step size will never exceed 1 day, and the simulation will span a total of 

20 days. Given these time step parameters, 44 time steps will be required for the simulation. 

To input the varying time step size, click on the 'Time Preview' button in Figure 1.34. This 

action will prompt a popup window of ‘Simulation Time Setting’, as shown in Figure 1.35. 

Then, type ‘NTIS (total number of the time steps) = 44, DELT (initial time step size) = 0.05, 

CHNG (multiplier factor - 1.0) =1.2-1.0 = 0.2, DELMAX (maximum allowable time step size) 

= 1.0, TMAX (maximum simulation time) = 20.0, KOUTSTEP_AUTO (number of time steps 

between outputs) = 1, TDTCH(I) (time at which the time step size is reset) = 10.0, and 

ITMSTO(I) = 1’. To check if the time step size has been entered correctly, click the 'Preview' 

button. Then, click on ‘Save’ button. 

 

Figure 1.35. Simulation Time Setting window. 
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6. To input the material properties, click the 'Edit' button under 'Material'. This will bring up 

the 'Material' window as shown in Figure 1.36.  

 

Figure 1.36. Material window. 

 

7. In Benchmark Problem 1, the domain is assumed to contain soil with a saturated hydraulic 

conductivity of Kxx = Kxz = 0 cm/day and Kzz = 10 cm/day, a porosity of 0.45, and a field 

capacity of 0.15. Consequently, when the 'Material' popup window appears, check 'Hydraulic 

Conductivity' next to 'Flow Property'. Additionally, enter the following values: 

 

⚫ Modified Media Compressibility = 0  

⚫ Modified Water Compressibility =0  

⚫ Saturated Water Content =0.45  

⚫ Hydraulic Conductivity xx = 0  

⚫ Hydraulic Conductivity zz = 10  

⚫ Hydraulic Conductivity xz = 0  

⚫ Fluid Referenced Density = 1  

⚫ Fluid Referenced Dynamic Viscosity = 865.7  

⚫ Bulk Density = 1.2,  
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⚫ Residual of Water Content = 0.15,  

⚫ Factor Exponent = 0. 

 

8. Click the 'Edit' button located beneath 'Water Retention Curves' as shown in Figure 1.36, 

then the ‘Water Retention Curves’ window will pop up as shown in Figure 1.37. 

 

 

Figure 1.37. Water Retention Curves window. 

 

9. In Benchmark problem 1, the unsaturated characteristic hydraulic properties of the soil are 

given as 

𝜃 = 𝜃𝑟 + (𝜃𝑠 − 𝜃𝑟)
ℎ−ℎ𝑎

ℎ𝑏−ℎ𝑎
 and 𝑘𝑟 =

𝜃−𝜃𝑟

𝜃𝑠−𝜃𝑟
 

where 𝜃𝑟 = 0.15, 𝜃𝑠 = 0.45, ℎ𝑎 = 0 cm, and ℎ𝑏 = -100 cm. Therefore, set the following 

values:  

 

⚫ Water Retention Curves (KSP) = -1 
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⚫ WCR = 0.15 

⚫ WCS = 0.45 

⚫ ha = 0 

⚫ hb = -100 

and click ‘Confirm’ to close the ‘Water Retention Curves’ window and click ‘Save’ and ‘Close’ 

buttons to exit the ‘Material’ window. 

 

10. After completing the input for 'Material', skip the input for 'Chemical' since Benchmark 

Problem 1 simulates fluid flow only. Then, proceed to the input for 

'Initial/Boundary/SourceSink' by clicking ‘Edit’ in Figure 1.34. 

11. When you click the 'Edit' button, the 'Initial/Boundary/SourceSink' window will pop up as 

shown in Figure 1.38. 

 

Figure 1.38. Initial/Boundary/SourceSink window. 
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12. In Benchmark Problem 1, the initial conditions are set as follows: a pressure head of -90 

cm is imposed on the top surface of the column, 0 cm on the bottom surface of the column, and 

-97 cm elsewhere. Therefore, input the initial conditions separately for the top, bottom, and the 

remaining areas. As shown in Figure 1.39, select 'Hydrological/Initial Condition' in the list box 

for the 'Spatial Type' and then click the button  . After that, in 'Conditions', select 

'Hydrological_Initial_top', 'Hydrological_Initial_bottom', and 'Hydrological_Initial_rest' in 

sequence. Then, enter the corresponding initial values into 'Initial Pressure' as shown in Figure 

1.39. 

 

 

Figure 1.39. Initial/Boundary/SourceSink window. 

 

13. In Benchmark problem 1, the boundary conditions are given as: no flux is imposed on the 

left and right surfaces of the column; pressure head is held at 0 cm on the bottom surface; and 

variable condition is used on the top surface of the column with a ponding depth of zero, 

minimum pressure of -90 cm, and a rainfall of 5 cm/day for the first ten days and a potential 

evaporation of 5 cm/day for the second ten days. Here, no flux boundary doesn't require any 
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additional input, so the input for no flux boundary can be skipped. The bottom boundary is set 

as a Dirichlet boundary with a hydraulic head of 0cm. As shown in Figure 1.40, choose 

'Hydrological/Dirichlet Boundary' in the list box from the 'Spatial Type', then click the button 

. In 'Conditions', select 'Hydrological_Dirichlet_Bottom' and click ‘Edit’ button. 

 

Figure 1.40. Initial/Boundary/SourceSink window. 

14. By clicking the ‘Edit’ button, the ‘ProfileInputForm’ window will pop up. Click the button 

 next to ‘Profile’ and type ‘0’ and ‘0’ for Total Heads in ‘Data Points’. 

 

Figure 1.41. ProfileInputForm window. 



30 

 

15. To set a Variable boundary condition on the top surface, select 'Hydrological/Variable 

Boundary' from the 'Spatial Type' dropdown menu. Then, click the button  , and in the 

'Conditions' section, choose 'Hydrological_Variable_top' as shown in Figure 1.42. Enter ‘0’ for 

‘Ponding Depth’ and ‘-90’ for ‘Minimum Pressure Head’. After that, click the ‘Edit’ button to 

input the ‘Profile’. 

 

Figure 1.42. Initial/Boundary/SourceSink window. 

 

16. By clicking the ‘Edit’ button, the ‘ProfileInputForm’ window will pop up. To input the 

'Profile', click the button . Because there's a rainfall of 5 cm/day for the first ten days and a 

potential evaporation of 5 cm/day for the second ten days in Benchmark problem 1, enter the 

values for 'Time' and 'Rainfall/Evaporation rate' as shown in Figure 1.43. Then, click the ‘Save’ 

button to close the ‘ProfileInputForm’ window, and click the ‘Save’ and ‘Close’ buttons to exit 

the ‘Initial/Boundary/SourceSink’ window. 
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Figure 1.43. ProfileInputForm window. 

 

17. Through steps 10 to 16, the input for the initial and boundary conditions has been completed. 

Under the 'Simulation' tab, you can view the input file generated based on the data entered so 

far as an ASCII file named 'Sim.inp' in the 'Model Input File' section, as shown in Figure 1.44. 

 

Figure 1.44. ‘Sim.inp’ file under Simulation tab. 
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18. In the 'Global' tab, as seen in Figure 1.45, you can view and modify the inputs for title, 

coupling iteration parameters, time step, material property, and unit. 

 

Figure 1.45. ‘Global’ tab. 

In the ‘Global’ tab, confirm that 'Data set 4' → 'Record 1' has 'NTIF = NTIS = 44'. 
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19. In the 'Hydro' tab, you can view and modify inputs related to iteration and optional 

parameters, material properties, initial conditions, sink/source, and boundary conditions. Since 

Benchmark problem 1 simulates the vertical flow of fluid flow, it should be set as 'Data set 3 

→ Flow Record 4 → KGRAV = 1' as shown in Figure 1.46. For matrix solution, choose the 

direct band-matrix solver (IPNTSF = 0). Furthermore, since the tolerance is set to 0.02, it 

should be configured as 'Data Set 3 → Flow Record 6 → TOLAF = 0.02, TOLBF = 0.02'. 

 

Figure 1.46. ‘Hydro’ tab. 

 

20. The input for the 'Model Parameter Input & Simulation GUI' has been completed. Then, 

click 'Start Model Simulation'  located on the upper left side of the program. 

Now, the numerical simulation is to be run through the 'Visualization GUI'  located on 

the upper left side of the program, and the results are to be examined. 

 

 



34 

 

1.3 Visualization GUI 

 

The Visualization GUI has the following five tools: Save , Add Task , Remove Task 

, Start , and Pause  as shown in Figure 1.47.  

 

1. First, to display the numerical simulation results, click the 'Add Task' tool . 

2. After selecting the appropriate Task, click the 'Start' tool . 

3. Click the 'Open' button  next to 'ParaView' in Figure 1.47. 

 

Figure 1.47. Visualization GUI window. 

 

4. Then, the ‘ParaView’ window will pop up. Choose ‘Pressure’ in the list box. 

5. In Figure 1.49, click the play button  to display the pressure head distribution. 
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Figure 1.48. ParaView window. 

 

Figure 1.49. Pressure head distribution. 


